6.8 SPC Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter · #1 ·
For some reason I had to re-register, have been a long term user of the forum and the 6.8

That being said, here is my problem with a lower right now....

I have multiple uppers....and lowers...have built many

This is the first time I have ever had a problem.

I have a upper that will work with any lower BUT the one I built for it...in fact that lower does not work with any upper.

I have replaced the buffer spring, the magazine catch (and adjusted it many times) and the bolt catch.

I have another carbine buffer on order.

But it will fire and eject the first round, then the bolt will jam on the next round. If will ALMOST lock the whole way back, save about 3/4 inch, on the magazine if I only load one round.

I have swapped springs, no difference.

I swapped buffers (why I ordered one) and it will feed just fine, but still doesn't lock the whole way back on an empty magazine.

On ever other lower I have the upper runs PERFECTLY.

It is a Spike's lower, with RISE drop in trigger.

KNS anti walk pins.

I have replaced everything BUT the bolt catch spring and and the buffer detent.

And lubed it all like crazy with CLP.

Thoughts? I am pulling my hair out on this one as it is my daughter's hunting rig and the season opens in 3 weeks.

Thanks!

S. Chris Anders
Lovettsville, VA
 

·
Premium Member
Joined
·
10,460 Posts
On you user account issue, there are a few posts in Site Updates that may point you in the right direction.

In the troubleshooting, do I understand correctly you are having a Failure to Feed/Short Stroke on this lower only?
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #3 ·
yup

correct...just this one lower.

About to order another buffer tube just cuz....last thing, except trigger, I would have to replace.

And the user name thing, no big deal, just didn't post on the new user forum as I have used the forum for many years.
 

·
Registered
Joined
·
844 Posts
For some reason I had to re-register, have been a long term user of the forum and the 6.8

That being said, here is my problem with a lower right now....

I have multiple uppers....and lowers...have built many

This is the first time I have ever had a problem.

I have a upper that will work with any lower BUT the one I built for it...in fact that lower does not work with any upper.

I have replaced the buffer spring, the magazine catch (and adjusted it many times) and the bolt catch.

I have another carbine buffer on order.

But it will fire and eject the first round, then the bolt will jam on the next round. If will ALMOST lock the whole way back, save about 3/4 inch, on the magazine if I only load one round.

I have swapped springs, no difference.

I swapped buffers (why I ordered one) and it will feed just fine, but still doesn't lock the whole way back on an empty magazine.

On ever other lower I have the upper runs PERFECTLY.

It is a Spike's lower, with RISE drop in trigger.

KNS anti walk pins.

I have replaced everything BUT the bolt catch spring and and the buffer detent.

And lubed it all like crazy with CLP.

Thoughts? I am pulling my hair out on this one as it is my daughter's hunting rig and the season opens in 3 weeks.

Thanks!

S. Chris Anders
Lovettsville, VA
The most likely cause, based on your description, is the drop in trigger assembly. Have you checked it for adequate clearance against the bottom of the bolt carrier? Does the hammer have enough clearance when the carrier pushes it down?
Before you you replace the buffer tube, remove the spring and cycle the rifle by hand to ensure nothing is impeding the carrier as it travels to the rear.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #6 ·
Humm... should there be any resistance at all? It takes very little effort to cycle the action back, but once it is back it takes lightly tapping the stock with the rifle pointed down to get the bcg to slide back forward....thanks for the advice?
 

·
Registered
Joined
·
1,185 Posts
Take the trigger out and hand cycle it, if it hangs up its a problem in the buffer system unless the bolt catch is dragging it.

The lower could be out of spec also
 

·
Registered
Joined
·
844 Posts
Humm... should there be any resistance at all? It takes very little effort to cycle the action back, but once it is back it takes lightly tapping the stock with the rifle pointed down to get the bcg to slide back forward....thanks for the advice?
There should be minimal resistance when the carrier travels to the rear, but some of mine hang up at the bottom of the tube and have to be jarred out. Since my gun functions fine, I assume that is normal.

I think you should look at the trigger assembly carefully. Also, and try to determine if the magazine rides high enough to interfere with carrier travel.
 

·
Registered
Joined
·
1,624 Posts
So it locks up when the carrier is to the rear? Check to see if the threads are cut crooked in the lower causing the buffer tube to be crooked. This would make it difficult for the carrier to move forward and drag really bad.
 

·
Registered
Joined
·
1,523 Posts
Use the contact us button at the bottom left hand corner of the page to get your old account back.
Slight thread drift, this still hasn't worked for me.
 

·
Registered
Joined
·
26 Posts
Discussion Starter · #12 ·
ok...

Checked out trigger, seems fine...buffer tube is straight....so....putting in new buffer weight, buffer tube detent and giving it another go.

If this does not work, it must either be the trigger- have stock ones hanging around (like a dozen) to swap, if that does fix it, then it must be the lower itself...it is a Spike's Crusader lower....

Thanks for the advise.

Chris
 
1 - 12 of 12 Posts
Top