6.8 SPC Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Just got back from the intial run on my new 6.8 build at the range. Pulled the trigger and it went boom like it is supposed to do. The bolt locked back like it was supposed to do. I put a mag in it and it cycled the first round out of the mag fine pulled the trigger and it fired and cycled the next round fine. I pulled the trigger again rifle fired but it malfunctioned. The bolt came back but didn't eject the empty case. Upon this it fed again so I need up with a double feed. Any suggestions would be much appreciated. I continued this same process over and over about ten times and it would double feed every time the third round from the mag. I would clear the malfunction and again the third round. I tried 4 different mags and it continued.
 

·
Super Moderator
Joined
·
11,796 Posts
Just got back from the intial run on my new 6.8 build at the range. Pulled the trigger and it went boom like it is supposed to do. The bolt locked back like it was supposed to do. I put a mag in it and it cycled the first round out of the mag fine pulled the trigger and it fired and cycled the next round fine. I pulled the trigger again rifle fired but it malfunctioned. The bolt came back but didn't eject the empty case. Upon this it fed again so I need up with a double feed. Any suggestions would be much appreciated. I continued this same process over and over about ten times and it would double feed every time the third round from the mag. I would clear the malfunction and again the third round. I tried 4 different mags and it continued.
When you tried with one round did the bolt lock back on the bolt face or did it catch the front of the carrier. It could be several things but I would try that again and see if it locks back on the bolt face. If snagging the carrier then I would check gas block alignment. If it is catching the front of the bolt like it should then I would clean it up good, oil it and cycle the action by hand a few dozen times and try it again.
 

·
Registered
Joined
·
1,484 Posts
It is a wilson bolt and carrier. It has a rifle buffer since it is setup as a rifle.
If you would list out your components that are relevant to the issue.
Barrel length, mid or rifle gas
Buffer type, spring type
Gas block type, adjustable/non adj.
BCG you said Wilson so assuming you have the NP3 coated LMT
List any signs of gas leaks
Magazines and ammo being used
 

·
Super Moderator
Joined
·
11,796 Posts
Most guys with mid gas are running carbine buffers.
Nothing wrong with mid gas and a rifle buffer system. There are more people with this set up than you may realize. It has always worked fine for me.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Ok more time on the gun today. I removed the gas block even though it was in line. Reinstalled it and manually cycled the action about 100 times. first 2 mags same thing not ejecting the second case. It is locking back on the bolt face not the carrier. Third and fourth mag it did what it is supposed to. Loaded 4 more rounds in one mag and it too was fine. Had to pack up because the range was closing. So I guess it may have needed a little time/break in? The steel plate was ringing at 200 yards every shot. That is so rewarding to hear that!!
 
1 - 10 of 10 Posts
Top