6.8 SPC Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
3,832 Posts
Discussion Starter · #1 ·
My PSA AR15/PA10 EPT has a problem of that wire that sits in the Hammer that runs through the connecting pin hole is blocking the connector pin that connects the hammer to the lower. I can lower it with a small screw driver from the end of top of the hammer. Where it catches one of the slots of connecting pin and you have to get it out using a punch to get it out as you lower the damn wire again. There is no way I think I can get it in the lower this way. Or even get it out if I put a better trigger group in.

Any IDEAS?
 

·
Registered
Joined
·
3,832 Posts
Discussion Starter · #2 ·
Called PSA they are sending me a new trigger group.

Seems the pin/wire/whatever inside the hammer isn't suppose to block the detent/connecting pin from going through with having to use a 3 handed maneuver to get it in by lowering the pin on the end of the hammer with pressure a small screw driver.

Also seems my dent pins were way to small as they slid through the hole on the trigger by gravity alone and there was a little wiggle in the pins when going through. Also part way in the hammer one also before it hit the blocking wire thingy. They said that wasn't suppose to happen also.

If I some how I did get it in I don't think I could of got it out with out having to drill the whole thing out if I wanted to get it out for cleaning or upgrade.

Other wise besides that, every thing put together smoothly and cleanly!
 

·
Banned
Joined
·
2,342 Posts
thanks, i'll keep my eye peeled, i've installed 3 of those with no problem at all
 

·
Registered
Joined
·
3,832 Posts
Discussion Starter · #4 ·
I think it was a fluke, every thing else fit well, the detent/pin would only go in if that wire was held down on the end of the hammer and that had to be oddly manipulated to get the detent/pin by it. A friend of mine said "ALWAYS PREFIT!" Seems to of saved me a lot of time.

Really what is that wire in the middle of the hammer suppose to be used for?
 

·
Banned
Joined
·
2,342 Posts
I think it was a fluke, every thing else fit well, the detent/pin would only go in if that wire was held down on the end of the hammer and that had to be oddly manipulated to get the detent/pin by it. A friend of mine said "ALWAYS PREFIT!" Seems to of saved me a lot of time.

Really what is that wire in the middle of the hammer suppose to be used for?
dunno what it's for, it's part of the channel on the bottom of the hammer, i have cussed a few of them LOL perhaps someone will jump in and tell us what it is, or i could check my usgi manual and see if it's mentioned. might just be to engage the pins that have the single center groove, i.e. keep the hammer in place on the pin
 

·
Registered
Joined
·
3,832 Posts
Discussion Starter · #7 ·
The pin inside the hammer where it comes out at the end I'm talking about.

What is that for? That's what caused it for me.
 

·
Registered
Joined
·
3,832 Posts
Discussion Starter · #8 ·
Well...first they sent me pins that were really not needed as they are the same size then the new hammer they sent wasn't the new enhanced...

Guess may as well as go with an ALG or RRA NM if a sale is around for one.
 
1 - 8 of 8 Posts
Top