6.8 SPC Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello to all members. After putting together four 5.56 AR's, I finished my first 6.8 this summer. It was a bit of a struggle here and there, but this forum was tremendously helpful. I used a Spikes Tacticle upper and lower with an AR performance barrel and bolt. A Vltor IMOD stock, tube and buffer and a Midwest Industries 15 inch SS rail. The rifle is black, with red highlights, such as trigger guard, receiver pins, safety lever and mag release.
Getting it to function was the struggle. First try it wouldn't eject or cycle. Took it apart and noticed the ejector plunger was stuck inside the bolt. I couldn't get it out so I contacted ARP and returned it to them. they fixed it and sent it right back. I had noticed and wiped off some little metal chips that looked like glitter, when I was putting it in the carrier and apparently one of these holdovers from machining had gotten between the ejector and the bolt body. back to the range and it still was not fully cycling. I had used a Seekins adjustable gas block and had it wide open. I switched it out for a non-adjustable block that I had and checked the gas hole/ block alignment. It still was short stroking, so I tried switching the Brownells m16 carrier for a light weight Voodoo carrier, and it started to work part time. it would lock back on an empty mag, but still had feeding problems. I read in this forum that because of closer tolerances that it might take a 100 rounds or so to break it in and start running right. I also, by someone's suggestion on here, sat and just worked the bolt many, many times.
I have three magazines. two are Stoner AR and one Barrett. Next attempt at the range, the 15 round Stoner mag started working pretty regularly, at around the 80 round mark. Things were still hanging up with the other two mags, both 30 round length mags. After 100 rounds it would run thru the Stoner mag without a hitch. I swapped the lightweight carrier out and went back to the M16 carrier and yesterday it fired all three mags without any malfunction. I had only been function testing thus far, so went to work sighting it in. It has Magpul flip up sights. First three rounds at 25 yards (to get on paper) were a clover leaf, all holes touching, that you could cover with a nickle. Moving out to 50, groups were under an inch. I put 60 rounds through it without a hitch. I'm using Federal 115 grain. After our current heat wave passes, I'll do all my shooting at 100 yards. I also have a pretty good supply of brass and look forward to reloading for the 6.8 this fall and winter. All my previous 5.56 builds worked great first time out, so this one was a little frustrating, but i am overjoyed with how it works now and thankful for the help I was able to gleen from this forum. I googled every question I had and they had all been answered on this forum. Glad you guys are out there.
 
1 - 2 of 2 Posts
Top