6.8 SPC Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
348 Posts
Discussion Starter · #1 ·
Well I've been testing my ar9 build and I'm having one issue.

The build, Spartan side charge upper, nfa bolt, 7.5" barrel, runner runner guns glock lower, cmc flat trigger, Oem glock mags.

The problem. I rack the slide first round loads fine, fires fine. Second round is picked up and loads fine, but when trigger is attempted to be pulled it is hard as a rock and won't pull to fire. If I sepparate upper from lower, trigger is reset and will pull just fine.

What could cause the trigger to not pull? Are the cmc triggers not compatible with the 9mm ar builds? I thought that the nfa bolts were cut to allow all triggers? Link to the trigger I'm using is below.

http://www.cmctriggers.com/products/standard-triggers/standard-trigger-flat/
 

·
Registered
Joined
·
1,065 Posts
I'm not really familiar with 9mm builds, but right on NFA's site it says use only triggers with milspec style hammers.


-Alexander
 

·
Registered
Joined
·
2,019 Posts
So when you pull the upper off are you resetting the trigger or is it already reset and ready to go when the upper is pulled off? I don't know of a really good way to check if the bolt is blocking the hammer in some fashion.

What happens if you cycle it with the slide two times does it fire?
Is this malfunction only happening when the bolt is cycled by firing a round?
Is the bolt all the way forward when it is cycled by firing?
 

·
Registered
Joined
·
348 Posts
Discussion Starter · #5 ·
So when you pull the upper off are you resetting the trigger or is it already reset and ready to go when the upper is pulled off? I don't know of a really good way to check if the bolt is blocking the hammer in some fashion.

What happens if you cycle it with the slide two times does it fire?
Is this malfunction only happening when the bolt is cycled by firing a round?
Is the bolt all the way forward when it is cycled by firing?
The hammer/trigger is reset on its own when I pull the upper. I pull the upper, and the trigger fires freely.

the bolt is all the way forward when this happens. If I cycle the gun by hand with no ammo it will function correctly. Add ammo to the mix and it starts having the issue.

Could the issue maybe be the last round hold open mechanism on the upper?
 

·
Registered
Joined
·
2,019 Posts
Could be. The upper I have does not have that feature and I have no issues but I have a regular mil spec trigger group.

Maybe try a mil spec if you have one laying around that will rule out the drop in if it has the same issue.
 

·
Registered
Joined
·
348 Posts
Discussion Starter · #8 ·
ramped bolts use a regular ar 15 hammer, unramped bolts must use a special 9mm hammer. Big difference
The NFA bolt can be used with normal milspec triggers. I'm working on getting one from a buddy to try so I can confirm if it's the cmc trigger causing the issue, or if it's something else
 

·
Registered
Joined
·
399 Posts
I jsut built one with PSA's Glock lowers and hybrid bolt, but it has no LRBHO. I used a mil-spec trigger I had laying around that came in a $50 LPK with JP Enterprises' reduced trigger and hammer spring sets. Would not go bang very often. I swapped out the hammer spring to the red extra power one and no light primer strikes any more. Runs like a raped ape.
 

·
Registered
Joined
·
2,019 Posts
So is the new trigger a drop in like the one that did not work or is it a regular mil-spec type? just curious for future knowledge when I replace the trigger I have in mine.
 

·
Registered
Joined
·
348 Posts
Discussion Starter · #12 ·

·
Registered
Joined
·
1,065 Posts
1 - 14 of 14 Posts
Top