6.8 SPC Forums banner

1 - 14 of 14 Posts

·
Moderator
Joined
·
10,536 Posts
Check what?
 

·
Super Moderator
Joined
·
21,652 Posts
Check what?
Agreed, looks like a video-bomb to get people to go to a Youtube page, in hopes to get a boost in views/likes. A new topic of discussion deserves some effort/thought on the part of an OP. :a02:
 

·
Registered
Joined
·
418 Posts
Discussion Starter #5
Agreed, looks like a video-bomb to get people to go to a Youtube page, in hopes to get a boost in views/likes. A new topic of discussion deserves some effort/thought on the part of an OP. :a02:
Huh its me making fun of myself for not putting my suppressor on correctly and showing others what can happen ...... But feel free to delete


Check me out on YouTube and Facebook
 

·
Registered
Joined
·
418 Posts
Discussion Starter #6
Suppressor no-no..... Baffle strike?


Heinous typos thanks to autocorrect.
No thankfully it came completely off before it loosened to badly , but I did crap myself a bit at first before I climbed in the tube and recovered the suppressor


Check me out on YouTube and Facebook
 

·
Moderator
Joined
·
10,536 Posts
That you have your can tightened on correctly


Check me out on YouTube and Facebook
Okay, I added that to your first post. Trying to avoid the appearance of "click bait". I also embedded the video for ease of viewing.
 

·
Registered
Joined
·
2,306 Posts
Had a 5.56 Saker launch from an 11.5" AR on the first shot. Obviously did not understand how the mount worked and it was not locking properly.


Send back to Silencerco with an explanation of exactly what I did and accepting responsibility for repair costs. They analyzed the problem and suggested the rear end of the can was not tightened properly causing the can not to lock on the muzzle brake. God bless them ... they fixed it for free and has not had any problems since. That and the free upgrades to the early Octane 9HDs arned my loyalty for sure.
 

·
Registered
Joined
·
3,209 Posts
That blows...off...













But seriously, that stinks. I'm like BigWaylon and was watching for movement. If it doesn't screw on, how does it attach and how did it come off?
At any rate, looks like you lucked out with no damage or injury.
 

·
Registered
Joined
·
418 Posts
Discussion Starter #12
Okay, I added that to your first post. Trying to avoid the appearance of "click bait". I also embedded the video for ease of viewing.
Thanks , understand the fuss now I thought tapatalk auto embedded but I'm guessing I have to type the code in ?


Check me out on YouTube and Facebook
 

·
Registered
Joined
·
418 Posts
Discussion Starter #13
It's feted for mont then uses teeth that ratchet down on the mount after looking at it the locking ring did not lock but it quit ratcheting so I'm guessing carbon build up was the issue


Check me out on YouTube and Facebook
 
1 - 14 of 14 Posts
Top